Перенаправление после установки!

Установка и настройка биллинговой системы.
webbymaster.ru
Сообщения: 43
Зарегистрирован: 2016-04-20 0:16:00

Перенаправление после установки!

Сообщение webbymaster.ru » 2016-04-29 15:48:20

Ну что? Свершилось! Перешел на выделенный сервер и сразу проблема.
Биллинг перенес штатно но при заходе на сайт перенаправляет что-то с http на https и видимо некорректно.

В общем, Load.php перенаправляет с http на https как только можно себе вообразить, в итоге зацикливается. Отключил эти перенаправляения в самом файле. http веб-сервер направил в другую директорию и сделал в .htaccess там редирект на https. Но сайт не работает. Нет страниц созданных вне сервера (имеется ввиду хостинга). Кнопки авторизации, входа и регистрации не работают.

Сайт не работает.

Прошу совета!

Отправлено спустя 47 секунд:
Крон ошибку шлёт: Bus error (core dumped)

Отправлено спустя 1 час 11 минут 45 секунд:
Как вариант устанавливать по-новой? Но тогда все настройки и труды жалко что сделаны были на shared-хостинг
Может можно как-то реанимировать?

Аватара пользователя
Alex Keda
Сообщения: 2816
Зарегистрирован: 2009-10-07 14:30:54
Откуда: USSR
Поблагодарили: 19 раз

Перенаправление после установки!

Сообщение Alex Keda » 2016-04-29 17:04:00

домен чтоле изменился?
Убей их всех! Бог потом рассортирует...

webbymaster.ru
Сообщения: 43
Зарегистрирован: 2016-04-20 0:16:00

Перенаправление после установки!

Сообщение webbymaster.ru » 2016-04-29 17:19:17

Нет

Отправлено спустя 2 минуты 31 секунду:
Всё осталось как и было, только перенёс на uvds

Отправлено спустя 4 минуты 25 секунд:
Сайт сейчас как с нуля, только логотипы мои. Не понятно. Такое ощущение что БД не подтягивает...Меню делал, нет его; статьи писал тоже нет. Ну и соответственно ни тарифов, ни серверов, ничего...

Отправлено спустя 42 минуты 53 секунды:
Крон такую ошибку сейчас пишет:

Код: Выделить всё

[: php: unexpected operator
Fri Apr 29 17:04:00 2016 (12355): Message Cached script '/pub/home/root/server/core/Load.php'
Bus error


Отправлено спустя 1 час 25 минут 10 секунд:
Откатил БД, восстановил сайт из бэкапа, заработал. Перешел в обновления, скрипт обновил core/Load.php И опять началось всё по-новой, о чем писал выше...
Страница swever.ru не работает
Сайт server.ru выполнил переадресацию слишком много раз.


Отправлено спустя 1 час 28 минут 26 секунд:
Если закрыть это:

Код: Выделить всё

#-------------------------------------------------------------------------------
if($Settings['UseSSL'] && IsSet($_SERVER["REMOTE_PORT"])){
   #-------------------------------------------------------------------------------
   // проверяем - ssl иил нет.
   if(!IsSet($_SERVER["HTTP_X_FORWARDED_PROTO"]) && $_SERVER["SERVER_PORT"] != "443"){
      #-------------------------------------------------------------------------------
      Debug(SPrintF('[JBs core]: прямое подключение без SSL, редирект на SSL'));
      #-------------------------------------------------------------------------------
      // редиректим на ssl
      header("Location: https://" . $_SERVER["SERVER_NAME"] . $_SERVER["REQUEST_URI"]);
      #-------------------------------------------------------------------------------
      exit;
      #-------------------------------------------------------------------------------
   }
   #-------------------------------------------------------------------------------
   if(IsSet($_SERVER["HTTP_X_FORWARDED_PROTO"]) && $_SERVER["HTTP_X_FORWARDED_PROTO"] != 'https'){
      #-------------------------------------------------------------------------------
      Debug(SPrintF('[JBs core]: проксированное подключение без SSL, редирект на SSL'));
      #-------------------------------------------------------------------------------
      // редиректим на ssl
      header("Location: https://" . $_SERVER["SERVER_NAME"] . $_SERVER["REQUEST_URI"]);
      #-------------------------------------------------------------------------------
      exit;
      #-------------------------------------------------------------------------------
   }       // закрытие - не ssl
   #-------------------------------------------------------------------------------
}
#-------------------------------------------------------------------------------
#-------------------------------------------------------------------------------


то начинает работать, но с ошибками...

Отправлено спустя 58 секунд:
В общем друзья, нужна помощь.
Заранее всех благодарю.

Аватара пользователя
Alex Keda
Сообщения: 2816
Зарегистрирован: 2009-10-07 14:30:54
Откуда: USSR
Поблагодарили: 19 раз

Перенаправление после установки!

Сообщение Alex Keda » 2016-04-29 22:34:10

webbymaster.ru писал(а):Источник цитаты

Код: Выделить всё

 [: php: unexpected operator

вот это - на что ругается-то?
с олтадкой запустите шелл скрипт

Код: Выделить всё

sh -xv /path/to/cron/script.sh
Убей их всех! Бог потом рассортирует...

webbymaster.ru
Сообщения: 43
Зарегистрирован: 2016-04-20 0:16:00

Перенаправление после установки!

Сообщение webbymaster.ru » 2016-04-29 23:15:10

Alex Keda писал(а):
webbymaster.ru писал(а):Источник цитаты

Код: Выделить всё

 [: php: unexpected operator

с олтадкой запустите шелл скрипт

Код: Выделить всё

sh -xv /path/to/cron/script.sh


Так а как? Сервер у провайдера. :-(
Ему путь нужен, а я не найду чего-то...

Аватара пользователя
Alex Keda
Сообщения: 2816
Зарегистрирован: 2009-10-07 14:30:54
Откуда: USSR
Поблагодарили: 19 раз

Перенаправление после установки!

Сообщение Alex Keda » 2016-04-29 23:17:31

и что что у провайдера?
у вас шелла нет чтоли?
--
а вообще, проверьте соответствие требованиям
http://www.joonte.com/Tech
Убей их всех! Бог потом рассортирует...

webbymaster.ru
Сообщения: 43
Зарегистрирован: 2016-04-20 0:16:00

Перенаправление после установки!

Сообщение webbymaster.ru » 2016-04-30 1:39:47

Чего-то я каталог /path/ не найду.

Отправлено спустя 1 час 1 минуту 12 секунд:
Простите нуба :-)

Отправлено спустя 9 минут 55 секунд:
Поставил на другой shared-хостинг

Код: Выделить всё

[00:45:53.48][42309] [!] [!!1024]-[JBs core]: не удалось загрузить базовый модуль в линии 670 файла /home/users/root/server/core/Load.php

Ваще ничего не пойму

Отправлено спустя 29 секунд:
Что с этим Load.php ?

webbymaster.ru
Сообщения: 43
Зарегистрирован: 2016-04-20 0:16:00

Перенаправление после установки!

Сообщение webbymaster.ru » 2016-04-30 13:50:16

Отбросил идею восстановления!
Установил заново и на выделенный сервер и на shared-хостинг.
Сайт не работает.
Сайт выполнил переадресацию слишком много раз.
ERR_TOO_MANY_REDIRECTS

Сервер полностью соответствует требованиям.

Отправлено спустя 2 минуты 38 секунд:
В логах:

Код: Выделить всё

[12:49:15.45][37824] [system/classes/auto/CacheManager.class.php]: Start initializing cache system.
[12:49:15.45][37824] [system/classes/auto/CacheManager.class.php]: Load MemcachedCache
[12:49:15.45][37824] Initializing memcahe system...
[12:49:15.45][37824] [Memcached]: memcached connected [version=1.4.25]
[12:49:15.46][37824] Cache system has been initialized.
[12:49:15.46][37824] [JBs core]: прямое подключение без SSL, редирект на SSL

Аватара пользователя
Alex Keda
Сообщения: 2816
Зарегистрирован: 2009-10-07 14:30:54
Откуда: USSR
Поблагодарили: 19 раз

Перенаправление после установки!

Сообщение Alex Keda » 2016-05-01 1:27:33

у вас в настройках принудительно SSL чтоли стоит?
Убей их всех! Бог потом рассортирует...

webbymaster.ru
Сообщения: 43
Зарегистрирован: 2016-04-20 0:16:00

Перенаправление после установки!

Сообщение webbymaster.ru » 2016-05-01 13:32:36

Христос Воскресе!
Не знаю что там было но вроде с помощью провайдера установили.
Новости только не работают. При открытии такая ошибка:

Код: Выделить всё

{"Exception":{"CodeID":"PROFILE_NOT_FOUND","String":"\u041f\u0440\u043e\u0444\u0438\u043b\u044c \u043d\u0435 \u043d\u0430\u0439\u0434\u0435\u043d","Parent":null},"Status":"Exception"}


Вернуться в «Установка и настройка»

Кто сейчас на конференции

Сейчас этот форум просматривают: [YandexBot] и 1 гость